Return to the Hybridizing Forum | Post a Follow-Up

 o
Help with brugmansia seed pod

Posted by mamabirrd z5 PA (My Page) on
Thu, Feb 12, 04 at 14:00

Hello....I'm new to this forum and have read lots of interesting things today. I had previously posted on the Brug forum, but haven't got an answer yet, so I thought i'd try here. I have an un-named brugmansia (peach-ish blooms) that recently developed a seed pod. I was quite excited, but stumped as to how it got there. I thought you needed two different blooming brugs for this to take place. I have cuttings in the greenhouse ('Frosty Pink' and some from the same un-named plant) but none have any blooms yet. Lots of other blooming plants, though. Anyone that can clue me in on this will make my day. Thanks!


Follow-Up Postings:

 o
RE: Help with brugmansia seed pod

Was going to answer but looked at the brug forum and saw that someone had already done so.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hybridizing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here