Return to the Hydrangea Forum | Post a Follow-Up

 o
Help! What's wrong with my Hydrangea?

Posted by dami13 7 (My Page) on
Mon, Jun 14, 10 at 8:51

Hi,
I have a beautiful old hydrangea, it was here when we moved in 8 years ago and was well established then. Its in a protected spot and has always bloomed beautifully. This year I noticed there was less foliage than usual and there are lots of smallish flower heads instead of the usual large fluffy ones. Now all the flowers are turning brown, but not really dry, they look dirty. I found a couple of leaves that have brown spots that could be anthracnose, but I think I would have expected more leaf damage. Here's a link to some pics. Please let me know if you have any ideas.

Thanks!

Hydrangea Pics


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hydrangea Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here