Return to the Hydrangea Forum | Post a Follow-Up

 o
Spots on leaves ?

Posted by Marshallkey none (My Page) on
Fri, Jul 5, 13 at 10:26

We planted this Hydrangea last year. It came in full bloom this year and is beautiful. I have not fertilifed yet this year. About a week ago I noticed the leaves turning a light green and now they have these spots. Can someone please identify this and suggest treatment . I see no insects . THX


Follow-Up Postings:

 o
RE: Spots on leaves ?

It looks a common fungal infection that afflicts hydrangea leaves. You can apply a fungicide that works on leaf spot or cercospora leaf spot or try not to over heard water the leaves and instead water the soil early in the mornings, provide good air movement by not planting other shrubs closeby, remove plant debris, etc. Dispose of the dried out leaves in the trash when the plant goes dormant do you do not spread the spores.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Hydrangea Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here