Return to the Impatiens Forum | Post a Follow-Up

 o
Problems with New Guinea Impatiens

Posted by KaeBoo_OK z6 (My Page) on
Tue, Jun 1, 04 at 13:37

I bought some NG impatiens for the window box on my porch. They were beautiful in the container, but now, a month later, they look horrible! The leaves started turning brown and curling, but they were still blooming. I picked off all the dead leaves. Currently one of them is only a few stems sticking up. I do detect small green shoots starting to emerge from one of the stems. The other two seem to be getting worse. They are planted on the north side of my porch that faces the east. It gets morning sun only until 10 or 11. Any suggestions?


Follow-Up Postings:

 o
RE: Problems with New Guinea Impatiens

Could be sunburn, but yours don't seem to be getting too much sun. Make sure they aren't getting a lot of reflected heat and are not behind glass. Could also be overwatering, they don't like to sit in soaking soil. Could also be fertiliser burn, they like some fertiliser but not very strong fertiliser.

Are the edges of the leaves brown and crispy? Do the leaves show yellowing and drop while still quite firm? Do the leaves show discolouration from the edges inwards, or patches all over the leaves?


 o
RE: Problems with New Guinea Impatiens

  • Posted by cathf2 z5/Boise ID (My Page) on
    Mon, Jun 7, 04 at 21:15

I am having the same problem and am on my second round. The leaves start to show discolouration from the edges inwards then turn crispy and brown. Mine are in sun for only about 1 hour day and are getting adequate water. I am thinking that maybe there was something in the potting soil I used that they do not like and maybe thay are getting burned. My leaves stay on, get wilty(even when they have just been watered) then the bottom leaves start getting brown and crispy. Any suggestions?
Thanks!


 o
RE: Plant doesn't flower

My zone is Cent N.Y. My plant is healthy, but no longer puts out flowers. Can I do anything?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Impatiens Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here