Return to the Impatiens Forum | Post a Follow-Up

 o
Why don't my Impatiens have flowers???

Posted by tinaw_2008 (My Page) on
Wed, Jun 11, 08 at 14:05

I planted my impatiens in pots about a month ago. The plants are doing GREAT, but there are very few flowers. Out of a whole flat, I have about 6 blooms. I see buds appearing, but then they're suddenly gone. Could something be eating them? Like I said, it's just the flowers, not the leaves. And not even the flowers that manage to bloom, just the buds. The only insects I see hanging around are ants. Do ants eat impatiens? HELP!!!


Follow-Up Postings:

 o
RE: Why don't my Impatiens have flowers???

Well I can tell you ant dont eat Impatiens. I am wondering what kind they are. Are they doubles? These are well know for dropping buds. I'm also wondering if birds think the buds are bugs and pulling them off.


 o
RE: Why don't my Impatiens have flowers???

I am having the same problem with the Fusion series of Impatiens. They have a TON of buds but they never open...just drop off.


 o
RE: Why don't my Impatiens have flowers???

No, they aren't double impatiens. I don't think the buds are dropping off, as I don't see any lying around. I suppose the bird thing is possible. I'm like a woman posessed with this whole thing. I go out there several times a day, or look out the window to try to catch someone or something in the act! :-D


 o
RE: Why don't my Impatiens have flowers???

I,too,have fewer flowers this year. Some have either died or are in the process of doing so. Others have a few flowers or buds but not close to the lush appearance of recent years.

I feel it has to be the Miracle-Gro( which has worked well in the past) or the Home Depot batch I got this year. They are in the same 4 locations as previously used and I'm watering them the same.

On another post coffee grounds and peat moss were advised. Worth a try.


 o
RE: Why don't my Impatiens have flowers???

This has happened to my impatiens in past years when I used Miracle Gro. Too much Miracle Gro makes for beautiful leaves but no flowers. I now just use slow release fertizer twice during the season and they are fine.


 o
RE: Why don't my Impatiens have flowers???

MiracleGrow is great if it'd stop RAINING!!!!!!!!!!!!!!!!!


 o
RE: Why don't my Impatiens have flowers???

The buds and flowers on my impatiens are being eaten by something, and I've never had this trouble before. Usually the buds are eaten before they have a chance to open. I can see they've been nibbled down to the stem; tiny remnants of the flower remain. The leaves are left undisturbed. Each time I check the plants a half dozen or more medium red ants are crawling on them. Even though people on this site have said that ants don't eat impatiens I'm going to spray the plants for ants to determine if that solves the problem. I'll let you know. I'd love to know if anyone figures this one out!


 o
RE: Why don't my Impatiens have flowers???

Zippity, I have has this issue all summer. My impatien flowers are being eaten - I see lots of ants on them, so I keep thinking it is an ant problem.

What did your issue turn out to be? I am on the 20th floor, so it isn't deer or anything like that - and I do not think it is a bird issue.

Fungus? Insects? Something else? Driving me nuts.


 o
RE: Why don't my Impatiens have flowers???

three things come to mind... first.. if it looks like something is eating them, look with a flashlight a couple hours after dark and see if earwigs, slugs or both are eating them.. then treat accordingly if necessary... sluggo or diatomaceous earth... otherwise, be sure you are not watering \ too much..give them a chance to dry out some between waterings,. then do not overfertilize them... that's all I can think of right now.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Impatiens Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here