Return to the Impatiens Forum | Post a Follow-Up

 o
Impatiens not blooming??

Posted by kgd25 Alabama (My Page) on
Wed, Jul 31, 13 at 9:56

I have had my beautiful impatiens all summer. They were growing fine, but became very leggy, so I read to cut them back. Now, they are growing very healthy, but not blooming. We have had SO MUCH RAIN this summer, so I am wanting to know if it is because of the rain?


Follow-Up Postings:

 o
RE: Impatiens not blooming??

To Kgd25, it sounds like people all over the U.S. are having problems with impatiens this year.


 o
RE: Impatiens not blooming??

Impatiens usually flower very prolifically. The only time I've ever had any not flower was just after I took them as cuttings. If you've just cut back the plant it will be putting all its energy into growing again and won't flower for a while. Good luck. Be patient.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Impatiens Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here