Return to the Impatiens Forum | Post a Follow-Up

 o
impatiens niamniensis problem?

Posted by marko204 none (My Page) on
Tue, Aug 13, 13 at 12:47

Hello,
My impatiens was recently cut back because it was doing so well that it got too large. now it appears to be showing some signs of deficiency or something (see photo), anyone know what is wrong? I keep the soil moist with frequent watering, they are in good amount of sun and like i said were doing very well not that long ago. any idea?


Follow-Up Postings:

 o
RE: impatiens niamniensis problem?

  • Posted by susanc Z9/Sunset 17 CA (My Page) on
    Sat, Aug 17, 13 at 20:19

Mine was having the same issue. About 2 months ago, I started giving it some weakly diluted fish fertilizer every few weeks, and it now looks great.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Impatiens Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here