Return to the Impatiens Forum | Post a Follow-Up

 o
Losing leaves

Posted by rodco zone 5 (My Page) on
Sun, Aug 26, 12 at 23:22

I always have great luck with impatients. This year they started off great. I am watering with drip irrigation, so there is no overhead watering.
In the past couple weeks all my plants have been loosing their leaves. Today I noticed in in other gardens.
Whats the story?
impt1

impt2

impt3


Follow-Up Postings:

 o
RE: Losing leaves

I'm sorry, it looks like the mildew disease wiping out impatiens globally.


 o
RE: Losing leaves

Look at the underside of the leaves, as that is where you will find the evidence of downy mildew (a white, velvety coating of spores). What state are you located in?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Impatiens Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here