Return to the Iris Forum | Post a Follow-Up

 o
iris blight?

Posted by irinah z5 NE (My Page) on
Sun, May 27, 07 at 9:17

I got new iris from Schreiners gardens last year (American Classics) and it is somewhat yellowing on all leaves which does not look like leaf spot and no evidence of borers. It has buds but stopped developing and buds that were due to open last week are still buds. Other irises around it look ok - green and normal.

What should I do? Cut it back? Pull out and discard? Any advice is greatly appreciated.


Follow-Up Postings:

 o
RE: iris blight?

Is this what you speak of? I am curious myself!
This is "Lady Friend"? All the buds were empty!
Photo Sharing and Video Hosting at Photobucket


 o
RE: iris blight?

RBlegend, it is not exactly like that - blooms are there but iris stopped developing right before blooms were supposed to open and leaves are yellowing. (I took a picture) I checked the blooms today and it looks like they are getting dry.

Here is a link that might be useful: American Classics picture


 o
RE: iris blight?

With the strange weather we have had - Probably a cold snap stunted growth somehow.We had in Feb, 80 degree weather for 2 days then freezes. This confused alot of my bulbs!


 o
RE: iris blight?

Irinah,
I was envisioning all of the leaves being totally yellow. But it looks as tho it is the tips of the outer leaves of the fans are beginning the normal summer die-off process.


 o
RE: iris blight?

I cut down the blooms stalk and inspected it - turned out the base of the buds where seed usually forms was rotten. Must be the rain (we got too much lately) but the iris rhizomes look healthy.

Oh well! There is always another year, 2007 with late freeze and too much rain was a bit of a disappointment - out of 30 new irises only 3 bloomed, out of 12 old ones only 4 bloomed. Couple "Art Deco" blooms on a Spring day were worth all the work though :)


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Iris Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here