Return to the Iris Forum | Post a Follow-Up

 o
Iris not blooming

Posted by collinw 7b (My Page) on
Wed, May 2, 12 at 14:23

We had an early spring and all of my early season iris bloomed about 2 weeks early. Then we had a cooler week, and now my middle season iris seem to be behind. They should be blooming now and they are not blooming. They have always bloomed reliably. Has anyone else every experienced this?

Thanks!


Follow-Up Postings:

 o
RE: Iris not blooming

I got the same weather patterns as you did but my irises are thriving more then they did last year odd enough. It might be that maybe your irises might be crowding each other. It's also not unheard of for irises to skip a bloom. It could be anything really.

But I'm sure if you give your irises some time and patience they could still bloom this year. Irises can be a bit tricky to predict.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Iris Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here