Return to the Iris Forum | Post a Follow-Up

 o
BlueJ Order Arrived, Diasappointing

Posted by oregonwoodsmoke 5 OR Sunset 1A (My Page) on
Sat, Jul 27, 13 at 21:22

I received some decent iris last year from Blue J, so I did another order for this year.

It's like I am received rhizomes from a different company. Last year, they were a bit smallish, but plump and healthy. They took off and grew well.

This year they are very small and not in very good condition. Many are 1/2 inch size. My order of 2 Japanesque consisted of a couple of dead leaves and some empty skin. But there is this tiny little 1/8 inch bump on the top of the empty rhizome which must be my $9 worth of plant.

My Dipped In Gold are both rotted and oozing some sort of foul smelling slime. I hope I didn't just import some nasty disease into my garden.

Only one of my plants from last year's order bloomed, so I don't know if they are true to name.

Right now, I feel very apologetic that I have recommended them so enthusiastically to so many people. I won't be ordering from them again.


Follow-Up Postings:

 o
RE: BlueJ Order Arrived, Diasappointing

That's awful. I hope you have alerted BlueJ. Before I had a digital camera I received an order from a different iris vender that was completely coated in green mold! The rhizomes were firm so I planted. I vowed never to order from them again. A couple weeks passed and another box arrived with the same order and no mold on it!

Thanks for alerting us to your experience this year. This link explains soft rot.

Here is a link that might be useful: soft rot


 o
RE: BlueJ Order Arrived, Diasappointing

I understand.


 o
RE: BlueJ Order Arrived, Diasappointing

Hi,
I just recently ordered off Ebay and mine were absolutely stunning.Just a heads up to check out Ebay. Will see what they look like next spring.

Ivy2003,


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Iris Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here