Return to the Iris Forum | Post a Follow-Up

 o
Addition of photos to HELP! question

Posted by terriebari 5 (My Page) on
Fri, Aug 15, 08 at 16:21

I asked the question regarding the brown, cramy stuff. I have removed the leave it was on, but noticed the top of the bulb is also a little sot. Here is a photo, if that helps any:

http://terriebari.myphotoalbum.com/view_photo.php?set_albumName=album10&id=iris1


Follow-Up Postings:

 o
RE: Addition of photos to HELP! question

Bacterial Soft Rot
terriebari's photo


 o
RE: Addition of photos to HELP! question

rot without doubt.

Is that mulching on your Iris bed?


 o
RE: Addition of photos to HELP! question

They had they same problem with their iris in the Display Garden at the U.W. Exp. Farm. She admitted that they were planted to deep.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Iris Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here