Return to the Beans, Peas & Other Legumes Forum | Post a Follow-Up

 o
leaves light green but growing

Posted by purnima z9CA (My Page) on
Wed, Jun 16, 10 at 16:20

Hi,

I planted the Insuk Wang Kong runner beans that Jim had sent me late last year in 5 gallon containers. The plants are doing great except that one of them has leaves that are really light green (almost yellow) but is growing vigorously. I think it is nitrogen deficiency. Is it? Should I add nitrogen-rich fertilizer?

Purnima


Follow-Up Postings:

 o
RE: leaves light green but growing

I had to add iron but my soil is alkaline. Are the veins dark with pale leaves. What is your pH? I got tons of flowers but no beans. They were great for attracting hummingbirds and pollinators, though.


 o
RE: leaves light green but growing

The veins are not dark. I have flowers but no beans yet. But my season is just starting.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Beans, Peas & Other Legumes Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here