Return to the Growing under Lights Forum | Post a Follow-Up

 o
Problem with fixture

Posted by trixylarue z7 NC (My Page) on
Sun, Nov 8, 09 at 11:12

Hello - I purchased a fixture a few years ago that has 4 T5 bulbs and 2 HPS bulbs built into it. I had to move right after buying it and I didn't have the space for it so it sat in a closet. But now after moving again I can use it. I set it up yesterday and it worked fine all day. Today the T5's won't stay on. They go on for a few seconds then off for a while and then back on for a few seconds.

Any advise on what might be causing this and what I can do to fix it? Obviously it's no longer under warranty. Thanks.


Follow-Up Postings:

 o
RE: Problem with fixture

Did you replace the bulbs?


 o
RE: Problem with fixture

I got an e-mail today from the company suggesting it might be a bad bulb so I am going to order replacements. Hopefully that is all there is to getting this corrected. Thanks.


 o
RE: Problem with fixture

Well the new bulbs made no difference. The lights still do not stay on. Any other suggestions?


 o
RE: Problem with fixture

I'd check the sockets to make sure they're not corroded and that the bulbs are seating properly. And I don't know how comfortable you are with this, but I would open it up and check all of the connections. That means tightening all of the wire caps and making sure none of the wires can be pulled loose. Of course you should do this when it's unplugged, if you choose to. The most difficult part may be finding a way to open the fixture.

If that does nothing, then the fluorescent ballast may need to be replaced. I bought a 4 bulb T5 ballast on ebay for $27 plus $10 shipping just to give you an idea.


 o
RE: Problem with fixture

Thanks for the suggestion and you hit the nail right on the head - the most difficult part is find a way to open it!

Thanks for the info on the ballast. I was wondering howmuch that was going to cost if that needed replacing - not a bad price considering what I paid for this thing several years ago! I can live with it.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Growing under Lights Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here