Return to the Lily Forum | Post a Follow-Up

 o
Mona Lisa Lilies

Posted by JennM84 East TN (My Page) on
Tue, Feb 18, 14 at 18:07

I received a potted Mona Lisa Lilies. It has 2 plants. When I got it 3 had already bloomed. And petals have fallen off. Another 1 has bloomed & there are 4 more that haven't bloomed yet. In the last 2 days 1 plant the leaves are falling off. I have only watered it once. It gets about 6-8 hours of sunlight. Am I doing something wrong? I'm new to Lilies. I would also like to know if & how I could put these outside. I love how beautiful they are & the fragrance is wonderful. Thank you in advanced. Any info on Lilies is welcome!


Follow-Up Postings:

 o
RE: Mona Lisa Lilies

This might help you.

Here is a link that might be useful: North American Lily Society


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lily Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here