Return to the Lily Forum | Post a Follow-Up

 o
id required please!

Posted by robertshaw2 none (My Page) on
Sun, Jul 13, 14 at 2:27

hi

i bought a large batch of lilies from parkes (uk), these were supposed to be 'yellow electric' but they arent. they stand about 1.4m tall, side facing flowers, no scent this morning but i thought one did yesterday eve when it was starting to open. any help with accurate id would be apprectiated so i know what to do with them in the future (to get the best results). thanks.


Follow-Up Postings:

 o
RE: id required please!

ps... i have tried google images but without success, one came close (yellow power) but is said to have upright facing flowers, these are definately side facing.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Lily Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here