Return to the Maples Forum | Post a Follow-Up

 o
whats wrong with these maples

Posted by clancy87 8 (My Page) on
Tue, Mar 25, 14 at 14:04

I have around 6 2 to 3ft UK's I planted in my garden last year. The other four are planted beside each other in a raised bed. The other 2 a katsura and a butterfly bush are planted in a normal bed. The two I mentioned started to leaf out about a month ago and we're looking great, but now the leafs to me look like they are dying back and shrivling back up. The others are all coming along great so im stumped to what's going on. There in a semi sheltered area and planted in a sandy loan bonsai soil


Follow-Up Postings:

 o
RE: whats wrong with these maples

Katsura


 o
RE: whats wrong with these maples

Butterfly bush


 o
RE: whats wrong with these maples

How moist is the soil? They could just be drying up as it gets warmer, especially as you have sandy soil in a raised bed. They probably haven't had a chance to put down many roots yet.


 o
RE: whats wrong with these maples

The final two pictures are the same.


 o
RE: whats wrong with these maples

Hi sorry was in a bit of a rush when i wrote this post. I will get another couple of photos up soon but as you can see my cameras not the best.

Sorry eibren. I meant to say the ones in the raised bed are fine, its the ones that are just planted in the ground that are dying back. Your right with the roots though, they were not very established when i planted them. I live in Scotland therefore we at least have rain every other day so the soils always moist. The only thing i can really think of is the past week we had a couple of days bad morning frost the sun all day. could it be they have been sun scorched.


 o
RE: whats wrong with these maples

Bad morning frost would do it, particularly if it got down to mid 20s F...


 o
RE: whats wrong with these maples

Yeah its frost damage. Seeing it all over now, everything's growing to early because its really mild here. I have 5 different maples and 20 seedlings growing about 2 meters away from these 2 and all of them are fine. I am baffled. Anyways thanks again for your help guys.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Maples Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here