Return to the Maples Forum | Post a Follow-Up

 o
Brown Spots / Leaves on Newly Planted Acer Rubrum

Posted by MrOctoberGlory 6 - MA (My Page) on
Thu, Jun 12, 14 at 21:33

I received 4 October Glory acer rubrum trees (smart pots) from a mail-order nursery (Sooner Plant Farm) and planted them on Saturday (day after they arrived). I soaked the root ball the day they arrived (after 4 days in transit) and soaked the entire dug-up area when planting to remove the air pockets from the soil.

Temperatures over the past week have been between 60 and 85 degress.

Leaves have developed brown spots as shown in the pictures. Thoughts on what's going on and how to correct?

Thanks!


Follow-Up Postings:

 o
RE: Brown Spots / Leaves on Newly Planted Acer Rubrum

Attaching another photo of the leaves


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Maples Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here