Return to the Maples Forum | Post a Follow-Up

 o
Two maples, two problems

Posted by idloveamocha 5 IL (My Page) on
Thu, Aug 1, 13 at 15:09

I have two maples in my backyard, one is an autumn flame maple, one an autumn blaze maple. Both are acting strangely this year.

Autumn flame maple: This tree has been in this location for 6 years--roughly 4" diameter at chest height, and overall probably 16+ feet tall. It has had some years of good growth (1'+ per season). This year, it is showing almost no growth. I see only two brances that have about 8" of growth, but the rest seems unchanged. In addition, I have never seen this tree produce as many seeds as it has this year. It set the seeds over a month ago, and they remain on the tree. Otherwise, the tree looks normal. Is something wrong?

Autumn Blaze Maple: This tree has been in this location for 3-4 years. We purchased it potted, and at the time, it was 4" diameter at chest height. It was obvious that the growers hacked the branches to 'shape' (ugh) it before selling. It is about 15' tall. This tree leafs out each year, and grows maybe a few inches, but definitely not the growth rate that I read about with autumn blaze maples. I realize that it takes a couple of seasons for a tree to 'take hold' and live up to its potential. However, I am wondering if 3-4 seasons is normal? I'll also mention I don't see much of a change in caliper yet, and no flaring at the trunk base yet. Otherwise, it looks normal.

Can anyone lend any insight?


Follow-Up Postings:

 o
RE: Two maples, two problems

Hello Mocha, maybe copy your post to the regular tree forum for more views. I don't knkw why GW must divide things soo in an age where my phone can view 100+ posts on a page.

The autumn blaze I might attribute to transplant shock. I have hear a year per inch of trunk. Last year was terribke here so I don't know how to count it.

In regards to the autumn flame I might hazard that last year's record heat and drought almost killed it and the excessive seeding is due to that. It was REALLY a bad year. Now I am seeing google earth pics of the area and everything was soo brown.

But yeah, it could be alot of things. Repost over in the generic tree forum with a pic of the whole tree and the trunk where it meets the soil. Then describe how ya planted it in detail and any watering patterns.

Good luck with em!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Maples Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here