Return to the Minnesota Gardening Forum | Post a Follow-Up

 o
'Bad' bugs in the garden

Posted by leaveswave (MN z4) (My Page) on
Sat, Jun 30, 07 at 13:57

The red aphids are absolutely coating the top two tiers of leaves on my cup plant stand. I've only seen a couple of ladybugs, where are they when I need them?!?

Anyone else noticed worse bug problems than usual this summer?


Follow-Up Postings:

 o
RE: 'Bad' bugs in the garden

I have aphids - all colors- like crazy, and the flea beetles! I have suck holes where they've tasted everything from hot peppers to my tomatoes, roses, and even milkweed!

-Marie


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Minnesota Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here