Return to the Native Plants Forum | Post a Follow-Up

 o
Salmonberry with a white flower

Posted by mooserider Seattle, WA (My Page) on
Sat, Apr 27, 13 at 14:10

I have a salmonberry that's a few years old. This spring it's been slow to put out leaves compared to the other salmonberries I have. It just put out a flower this week... no leaves yet, and the flower is white. I've never seen this before, has anyone else? Every years so far until now it's had the normal pink flowers.


Follow-Up Postings:

 o
RE: Salmonberry with a white flower

It may be stressed at root level. Since its not leafing out there seems to be something going on underground. The closest comparison I can come up with is my rose of Sharon that bloomed without leaves, then died from cotton root rot.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Native Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here