Return to the Native Plants Forum | Post a Follow-Up

 o
Leaf drop on milkweed, Asclepias incarnata

Posted by MCoffield 7b (My Page) on
Tue, Jun 18, 13 at 18:04

I have worked at a garden center for many years and have observed yellowed leaf drop on our young (less than one year) plants beginning at the base, in mid-summer. There is no obvious fungal or aphid cause. Anyone know what the cause could be?? thanks


Follow-Up Postings:

 o
RE: Leaf drop on milkweed, Asclepias incarnata

Probably a natural characteristic.


 o
RE: Leaf drop on milkweed, Asclepias incarnata

is she getting enough water? mine did best close to a down spout.


 o
RE: Leaf drop on milkweed, Asclepias incarnata

  • Posted by ericwi Dane County WI (My Page) on
    Thu, Jun 20, 13 at 9:54

If this is a potted plant, it could be that the pot is too shallow. Milkweeds are tap-root plants, and they really need to be in a pot that is 12 inches deep, in order to thrive.


 o
RE: Leaf drop on milkweed, Asclepias incarnata

Last summer, I bought an Asclepia pupurea. It was a young plant and had no blooms. The leaves started to turn yellow after a couple of weeks in the ground. The yellowing started from the base of the smaller stalks and worked its way up until I lost the those stalks.

Since I still had three larger stalks left, I moved it to a drier location (southwest sun on a slight slope). Here it is today. Sorry that the picture is blurry. There was a slight wind.

I know that the incarnata likes more moisture than the pupurea. The incarnata is doing well in the same spot where the purpurea was.

-Tina


 o
RE: Leaf drop on milkweed, Asclepias incarnata

  • Posted by cghpnd 7 / Virginia (My Page) on
    Fri, Jun 21, 13 at 11:57

I had/have the same exact problem. Day and night I'd watch closely. I found numerous slugs feasting on all of my milkweed. Well they haven't been on there in the last 2 nights n I haven't had yellow leaves. Yet....

This plant is 5 months old.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Native Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here