Return to the New England Gardening Forum | Post a Follow-Up

 o
Are Your Brugmansia Blooming Yet?

Posted by arbo_retum z5 ,WinchstrMA (My Page) on
Tue, Sep 14, 10 at 18:08

I have one bud showing out of 5 pots. You?
best,
mindy


Follow-Up Postings:

 o
RE: Are Your Brugmansia Blooming Yet?

Mindy - Mine blooms pretty much constantly - from late Spring until I bring it in in the Autumn. They are REALLY heavy feeders. Give them a half dose of Miracle Grow or the equivalent every other time you water them. If you haven't been fertilizing them start off with a full dose. Good Luck!
Deb


 o
RE: Are Your Brugmansia Blooming Yet?

deb, REALLY??!! from SPRING? plse give details about that.i can think of nothing better!
how do you overwinter them; when and where do you bring them after overwintering; what do they look like when you start the heavy fertilizing(which i have been doing the last 1.5 months but not before)?
thanks so much.i mean, why the heck do i grow these things if i can't get lots of blooms?? in winter they take up half of our tiny 1740 cellar!
thnx much deb,
mindy


 o
RE: Are Your Brugmansia Blooming Yet?

Mindy - In our old house I brought them in to the house at the end of the season and when they started to look especially bad I put them in the cellar to go dormant and then just brought them up in the spring. I don't start feeding them until I put them outside. This past year - no cellar, so I had to keep them in front of a sunny window and they got aphids halfway through. Really looked sad - what a mess. Every time I found a ladybug in the house I would put it on my poor brug. They started to eat them, but then I noticed a new infestation that I didn't recognize. Then I realized that they were little ladybug larvae. They were scooting around that plant like little Roombas eating all the aphids. By the time I was ready to put it outside permanently, the aphids were gone baby gone. Not to rub it in or anything (much), but I had so many blooms at one time this Summer that they were breaking branches. I counted 65 blooms and buds at one point. Mostly they come in waves as I don't remember to fertilize as diligently as I am recommending. The dwindling number of blooms act as a reminder. This is a plant that I got at a swap from Virginia a few years ago. Her mother breeds them I believe. It is a huge monster now. Are any of yours unbranched? They don't start to bloom until they have a stem that looks like a "Y". I have no idea why.
: D


 o
RE: Are Your Brugmansia Blooming Yet?

I have two going right now and they are both blooming like crazy. Yes, lots of fertilizer and water on a regular basis to keep these blooming machines going.

I overwinter mine in the basement under flourescent lights. Takes a lot of room, but the blooms in the winter are well worth it. I only did that one year. Since then I just take cuttings in the fall and pot them up and keep in the basement. The cuttings grow to 4-5' tall in no time and start blooming around July.

The one time I overwintered the whole plant, it not only bloomed in the basement in the winter, it started right up again when it went outside. It just keeps cycling through bloom periods no matter what.

Below is a link of some photos with captions of some parts of the process. I put this album together for a recent brug-convert friend.

Here is a link that might be useful: overwintering brugs pics


 o
RE: Are Your Brugmansia Blooming Yet?

I have an Inca Gold that pretty much blooms through the summer (it's on its 3rd flush of blooms now). I have one that should be in bloom this PM - not sure of the variety -it was picked up for a few dollars at Logee's with a "lost tag" note. Then I have what must be the yellow species which is huge and covered with buds - it does not consistently bloom before it gets cold - last year I had to bring it in - it bloomed but the scent was so strong I had to take the blooms off! I agree with cloud 9 - lots of fertilizer.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the New England Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here