Return to the New to Gardening Forum | Post a Follow-Up

 o
Forsythia gone limp

Posted by UrbanGardner100 none (My Page) on
Fri, Aug 30, 13 at 0:03

I have a Forsythia plant that just doesn't seem to be doing all that well. I've watered it properly and mulched it. Most recently I added some compost to it but it's still hasn't done anything to really help. I would feed it miracle grow food every few weeks but that hasn't helped either. The leaves are limp and no matter what I try these just don't perk up as it used to. It's a young plant that I got earlier this year. Anyone have any suggestions? Thanks


Follow-Up Postings:

 o
RE: Forsythia gone limp

Same thread w/ some responses at
http://forums.gardenweb.com/forums/load/newgard/msg082225598834.html?2

(Also has an image.)

Here is a link that might be useful: go to same thread to respond


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the New to Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here