Return to the Northwestern Gardening Forum | Post a Follow-Up

 o
artichoke disease

Posted by Evie123 BC (My Page) on
Tue, Feb 12, 13 at 11:12

hi-1st posting. I'm growing artichokes in Victoria, BC, and the 1st bud is always fine. After that, some of the buds get a brown shriveling on the top,and the leaves develop a yellow band along the edges with brown spots later developing in the yellow band. I can't find any pictures of either viral or bacterial or fungal diseases that could be causing this. I am also wondering about a possible calcium deficiency? Thanks!!!


Follow-Up Postings:

 o
RE: artichoke disease

Perhaps water shortage or erratic supply?

- What method do you use to water?
- How do you determine when to water?
- How do you determine you've applied enough?
- How wet, dry or moist does the soil before you water again?

This is from California but may provide some insights
http://www.ipm.ucdavis.edu/PMG/GARDEN/VEGES/artichokes.html

Here is a link that might be useful: growing artichokes & more


 o
RE: artichoke disease

I'm using overhead watering, and the soil stays pretty moist. It is mulched with the leaves, I water twice a week.the powdery mildew pictures on your link look like my leaves, but the gray mold describes the buds being affected.so I will try this year pulling back all the leaves, for the summer,and watering really early in the morning, less frequently.thanks.

I would love to see some diagnosis that accounts for the buds and the leaves at the same time,but will certainly try any idea.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Northwestern Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here