Return to the Ozarks Region Forum | Post a Follow-Up

 o
Japanese Beetles

Posted by sunnyside1 z6/SW Mo. (My Page) on
Thu, Jul 3, 14 at 2:24

Anyone have any JBs this year? My crepes were so late coming and haven't flowered long, but I haven't seen a one. Didn't even see a June bug in June. Strange.
Sunny


Follow-Up Postings:

 o
RE: Japanese Beetles

I've been seeing them just in the last week or so. It seems like they were later this year than usual. I was hoping the cold winter had killed them all.


 o
RE: Japanese Beetles

How do you treat for them once they arrive?


 o
RE: Japanese Beetles

I have seen a few. Stink bugs are my big problem. Squash bugs got a squash plant - nothing new about that.


 o
RE: Japanese Beetles

I haven't seen them yet this year either. I figure they'll be here anytime now...

I use Sevin dust. I hate using it, so much, but none of the organic methods I've tried work on them.


 o
RE: Japanese Beetles

I usually just let J. beetles eat whatever. Sometime they attack weeds which is OK with me. I don't have any roses blooming. If I had roses I might spray them.


 o
RE: Japanese Beetles

I have a few on various things; they are waiting for the blackberries to get ripe! I spray with Sevin thinking the more I kill the fewer will breed and reproduce more for next year!

The big draw here was rhubarb, kiss me over the garden gate, roses and a scattered few on the beans.


 o
RE: Japanese Beetles

We must have lucked out this year. Remember other seasons when we had what seemed Millions?

Dirtguy, in the past I have sprayed every single one I saw on my crepe myrtles from a bottle of liquid Sevin early morning and just before dark. And not if I see a honeybee nearby. I feel bad using Sevin, but it's the only thing that works for me.
Sunny


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Ozarks Region Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here