Return to the Palms & Cycads Forum | Post a Follow-Up

 o
Washingtonia fast becoming yellow after planting

Posted by Ronis Florida (My Page) on
Sun, Feb 10, 13 at 13:56

After planting Washingtonia Robusta trees (7-8 days later) started browning ends of foliage and yellowing a lot.


Follow-Up Postings:

 o
RE: Washingtonia fast becoming yellow after planting

how often are you watering?


 o
RE: Washingtonia fast becoming yellow after planting

Mine took a month or so to become accustomed to its new location. Let the fronds yellow completely before trimming. As mentioned previously don't over water. Were they pot grown?


 o
RE: Washingtonia fast becoming yellow after planting

The Washy's arent accustomed yet to the new location. They will be in shock for sometime until they are established. No worries, just dont try to over water. You'll be ok.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Palms & Cycads Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here