Return to the Passiflora Forum | Post a Follow-Up

 o
edulis

Posted by karyn1 MD 7 (bhkalen@aol.com) on
Sat, Aug 16, 08 at 21:22

One of the edulis that I grew from seed finally bloomed. It's taken about 2 years. I have another that was started about the same time that has yet to bloom. I've heard that sometimes they don't bloom at all. How long should I give it before deciding that it's never going to produce a flower?
Karyn





Follow-Up Postings:

 o
RE: edulis

Hi,

I had my P. edulis bloom for the first time this year too. About half of the flowers never opened - just fell off. But I still got about 50 flowers on my vine. Once the bud opened up then the flower didn't fall off.

Tomas


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Passiflora Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here