Return to the Peonies Forum | Post a Follow-Up

 o
Holes in my peony buds

Posted by cleemc NC (My Page) on
Fri, May 27, 11 at 16:36

this year i found something was eating the buds on my peonies. they are 4 years old and until this year have been perfect. also, there were tiny red bugs inside the large blooms. i have been to many places for help with this but nobody seems to know what the trouble was. 2 possibilities are thrips which caused the big holes in the buds and red spider mites....Help.


Follow-Up Postings:

 o
RE: Holes in my peony buds

Thrips don't cause holes. Neither do mites. More likely a caterpillar.

Any chance of pictures?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Peonies Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here