Return to the Peonies Forum | Post a Follow-Up

 o
Peony buds not opening

Posted by moneysaver 5b (My Page) on
Fri, Jun 24, 05 at 15:44

I had about 3 blooms open, the rest are not opening and dying off. Leaves are turning yellow. I did fertilize with Miracle Grow. Any suggestions or comments?


Follow-Up Postings:

 o
RE: Peony buds not opening

I can not stress this enough..... Peonies should be fertilesed in the fall and with a 5-10-5 which is a weak fertilisier. Bone meal is best as it is a 5-10-5 with other plant foods added. DO NOT LET FERTILISER CONTACT THE CROWN OR THE ROOT DIRECTLY!!! Place the fertilisier in a ring around the peony and work it into the soil around the peony.
As to the well known soil mixture that you used, it has a tendency to BURN peonies. It is for POTTED PLANTS that are in the nature of needing stronger fertilisiers due to being in pots and lack the abality to get any other nuetrition except for what is in that pot.

Your peony will now do what is called "BUD BLASTING" and will start sheding the blooms and you may lose all the top growth. Do not be alarmed, as the tops will come back next spring.

One other thing this well known mixture does to peonies is it holds moisture keeping the root wet and not only burns the root, but causes the root to begin rotting which is fatel to a peony. Peonies are a drought resistant plant and do not need a lot of water. once established it is usually not necessary to water them more than a couple of times in the winter and a couple of times in the summer. After established and 2 years old here in the midwest where the winters are cold and dry and the summers are over 100 degrees I do not water them at all and they do just great.

SOLUTION: Wait it out and the mixture will break down in 60 to 90 days, and make sure that you are not overwatering. They should be OK next spring.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Peonies Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here