Return to the Garden Clinic Forum | Post a Follow-Up

 o
purple plague

Posted by jerryca 9CA (My Page) on
Sat, May 3, 14 at 0:07

Dark purplish patches (lots of them) have suddenly appeared on my "Ghost Plant" succulents as well the Kiwis and Black Prince Echeverias. Is it some type of fungus and, if so, can it be treated?

Many thanks for any suggestions!

Jerry


Follow-Up Postings:

 o
RE: purple plague

Any change in your plants?
Perhaps environmental damage. Heat? Cold?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garden Clinic Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here