Return to the Garden Clinic Forum | Post a Follow-Up

 o
My Weigela doesn't look right

Posted by bernadette_gourder 5 from Newaygo, MI (My Page) on
Mon, Aug 9, 10 at 19:12

I bought a potted Weigela, Wine and Roses, this past Spring. It doesn't seem to be doing that well. Can you tell me what might be wrong with it, if anything? If there is something wrong with it, what can I do? Is it fatal?

Thank you for any help you can give!

Bernadette

Here is a link that might be useful: Photos of my shrub


Follow-Up Postings:

 o
RE: My Weigela doesn't look right

  • Posted by jean001 z8aPortland, OR (My Page) on
    Mon, Aug 9, 10 at 22:36

Looks like the roots are short of water. Make certain the original rootball gets the water.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Garden Clinic Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here