Return to the Plumeria Forum | Post a Follow-Up

 o
Tree has no leaves but has alot of blooms

Posted by plumiegirl26 20 (My Page) on
Wed, Jul 14, 10 at 16:37

15 year old plumeria tree, blooms every year but this year has no leaves. Plenty of flowers. Should I worry?


Follow-Up Postings:

 o
RE: Tree has no leaves but has alot of blooms

Maybe; maybe not. Where are you located? Is it in the ground or in a pot? Need more info. A photo would help. Are the stems and root system OK?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here