Return to the Plumeria Forum | Post a Follow-Up

 o
Plumeria

Posted by jrjoseph Hou. TX (My Page) on
Mon, Apr 7, 14 at 23:58

I did not bring my plumeria's this winter they have a lot of damage on them. Pretty soggy stems I have cut them back but they seem like they still need to be cut back more. They have not started to produce any leaves. Do I need to cut back more or are they dead? Please help.


Follow-Up Postings:

 o
RE: Plumeria

May we see some pics? Please

Chuy


 o
RE: Plumeria

If they are still brown inside you'll have to cut until you see clean, white wood. Sterilize your shears in between cuts or it will spread the rot even more. As Chuy mentioned, if you have pictures we can see it might be easier to give you more advice.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here