Return to the Plumeria Forum | Post a Follow-Up

 o
I think I lost my Scott Pratt *sad face*

Posted by sjp8987 9 (My Page) on
Tue, May 18, 10 at 21:00

I was so excited for spring to come to see if I would get any deep, red flowers from my Scott Pratt - I was even excited to see the tip of my grafted plant get shiny. However, I noticed that it wasn't leafing out like all the others so I poked it with something sharp - no sap :-( The grafted half and the stock half are both firm but no sap :-(. Do y'all think it's dead? The soil is dry right now so it shouldn't have root rot


Follow-Up Postings:

 o
RE: I think I lost my Scott Pratt *sad face*

Is the tissue green/white if you dig out a small piece with your fingernail or is it brown? If it's still green and firm it might be fine. Maybe it's dehydrated and no sap is running? That's just a guess. I'd try watering with some epsom salts and Superthrive. I'm surprised that's it's not already leafed out in your zone. Good luck.


 o
RE: I think I lost my Scott Pratt *sad face*

It's green and the middle is white, there's just no sap. I'll try watering again - I'm just afraid to water too much w/o any leaves. The soil is completely dry now. I won't lose hope yet! The only thing that worries me is that the stock plant to which it is grafted doesn't have sap either....


 o
RE: I think I lost my Scott Pratt *sad face*

A rooted plant needs to be watered. the main danger is overwatering a non-rooted cutting. Just water it in the morning on a warm day and let it drain and dry down in the afternoon. Once a week should get it going.


 o
RE: I think I lost my Scott Pratt *sad face*

THANK YOU everyone who suggested watering my plant. It was dehydrated! I didn't want to reveal at first that I had lopped off the claws to see if it was rotting inside - but I did *gasp!* So, now it's not as pretty as it was, but I can see new growth coming! Oh I am so so excited. It's still not leaking sap when I poke it, but it's not dead! I'll post some pictures later if you promise not to be disappointed that I cut the top off :-D

Sam


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here