Return to the Plumeria Forum | Post a Follow-Up

 o
Picture of plumeria

Posted by canelita-2 10 (My Page) on
Fri, Jun 13, 14 at 19:51

This is how it looked when it was attached to the inflow....


Follow-Up Postings:

 o
RE: Picture of plumeria

It looks to me like something damaged the petals when they were overlapped or furled up as a bud. It could be insect damage. Some leaves look like they have signs of spider mites.

I would give the leaves (top and bottom) and branches a nice wash with a garden hose to knock off any insects for a couple a times a day for a couple days. If that doesnt work then use Bayer 3 in 1 or Neem oil. Good luck.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here