Return to the Plumeria Forum | Post a Follow-Up

 o
purple jade dragon let down

Posted by tdogdad Zone 9 (My Page) on
Tue, Nov 2, 10 at 2:40

Been waiting for my purple jade dragon bloom to open and then the rain caused it to drop off. Two buds remaining. I think the cold killed the color.

Uploaded with ImageShack.us


Follow-Up Postings:

 o
RE: purple jade dragon let down

Hey Bill,

That is still a beauty of a bloom..Please post pics of the others that will hopefully bloom for you.

Take care Bill...

Laura in VB


 o
RE: purple jade dragon let down

Seriously, Bill, your let-down is better looking than any bloom I've had!

Jen


 o
RE: purple jade dragon let down

It's beautiful Bill.

Dewaine


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here