Return to the Plumeria Forum | Post a Follow-Up

 o
a predicament....

Posted by jost4318 none (My Page) on
Sat, Nov 9, 13 at 14:46

So I have an aztec gold and it has an inflow growing out of every single one of its 5 growth tips (two of which just started blooming). ever since these inflows have started developing the baby leaf nodes on the plant have been dying and falling off while the stalk continues to grow. the plant has been left with no new leaves to replace the old leaves which have now mostly died and fallen off. at first I thought this was just due to the plant going dormant however my other plumerias have not started dropping their leaves yet. I am wondering if I should keep all the inflows on the plant or if I should cut a few off. also If I do cut them off early will the plant still branch out normally? I am located in the orlando area our current highs are around 80 and our lows are 60-65


Follow-Up Postings:

 o
RE: a predicament....

Any chance its related to insects? When it was dropping leaves were the dropping from the lower parts of the branch first?

At this point i would not cut anything off. If the plant cannot support the blooms it will fall off naturally. Some plants may start hibernating earlier than others so maybe Aztec is ready to call it quits for the season.


 o
RE: a predicament....

I, too, would just leave it alone. Mine will drop leaves if it doesn`t get enough water, you look at it wrong, the wind blows, it`s the only plumeria I have ever had that loses leaves like this. Grows like crazy though. It`s getting moved across the alley next year cause I am tired of picking up the leaves from the porch.
Tally HO!


 o
RE: a predicament....

If I had temps like that, I would let them decide..

Good luck!!! I have to force because of space reasons and the sudden cold snap that always appears around this time of the year. If I have mild temps, I would let Mother Nature decide... IMO of course...

Take care,

Laura


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Plumeria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here