Return to the Rose Gallery Forum | Post a Follow-Up

 o
My First Bloom

Posted by Sara-Ann z6b OK (My Page) on
Thu, Apr 24, 14 at 9:55

This is my first bloom of the season, Our Lady of Guadalupe. Not a great picture, took it with my new iPhone, I have a lot to learn about taking pictures with it. There are quite a few buds on my roses, I am anxious!

OUR LADY OF GUADALUPE


Follow-Up Postings:

 o
RE: My First Bloom

Nice Sara-ann. Is it fragrant?

Lynn


 o
RE: My First Bloom

Thank you Lynn. Right now it has a very light fragrance. It is a sweet rose, think I am going to like it.


 o
RE: My First Bloom

Oh Sara Ann, That's a beauty! I've never seen OLoQ in person, but have always heard good things about her. Some of my OGRs have started blooming this week, but no blooms open on my moderns yet...a bunch of buds, though :) I'm getting very excited and anxious, too!


 o
RE: My First Bloom

Thank you Pat. I am so happy that your roses are beginning to bloom and can't wait to see your beautiful pictures!


 o
RE: My First Bloom

How exciting seeing the first bloomer! I'll let you in on a secret. As much as I love my floriferous Lady, I find her very difficult to photograph. I don't know why, but her blooms just don't look special when I photograph them, no matter how many I take. So it may not be just a problem with your iPhone camera.

No blooms yet, but I did see some red showing on the Home Run buds. Raining today, so maybe in a day or two I'll have my first bloom also.

Kate


 o
RE: My First Bloom

Lovely bloom. I bet you can't wait for all of those other buds to open.
Ain't Spring wonderful.

Suebelle


 o
RE: My First Bloom

Thank you Kate and Suebelle. You both have gorgeous roses, such a pleasure to see them. Kate, they will be in full bloom before we know it. I am so glad you are getting rain, we keep getting just a little, supposed to rain tomorrow, hope we get it a good one, without the hail of course!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Rose Gallery Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here