Return to the Organic Rose Growing Forum | Post a Follow-Up

 o
Alfalfa Tea Problem?

Posted by foxglovema z6/ma (My Page) on
Wed, May 12, 04 at 16:05

I'm making my first batch of alfalfa tea and have some questions. I started it last friday per instructions from a Rose forum friend.... 1/2 bag (a little less, actually) in a 30 gallon garbage container, fill with water, stir. Let sit. Stir daily....etc. for a week and then gleefully feed stinking liquid to the roses....
Well, today it is the consistency of thick oatmeal - very hard to stir. There is almosts no liquid in the garbage container. Did I do something wrong?
Thank you for your help!
Foxglovema


Follow-Up Postings:

 o
RE: Alfalfa Tea Problem?

Twas answered on the other forum, so let it start down. (3x or 5x too much alfalfa.)


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Organic Rose Growing Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here