Return to the Rose Propagation Forum | Post a Follow-Up

 o
Question on Root Cuttings

Posted by donnam_2007 VA (My Page) on
Sat, Jul 11, 09 at 10:43

I successfully got two rose cuttings to root. However, they have not sprouted any new leaves. Is this normal? Also, I just planted them in regular potting soil. Is it ok to put them outside now (in the shade for the time being)? Thanks for any help you can give me.


Follow-Up Postings:

 o
RE: Question on Root Cuttings

I would acclimate your cuttigs to open air gradually, as it's probably used to humid conditions. As far as new growth goes, it should sprout leaves when it's ready. I didn't get any significant new growth until the following spring. I speak from very limited experience......so I hope that helps.

CJ


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Rose Propagation Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here