Return to the Salvia Forum | Post a Follow-Up

 o
salvia not blooming

Posted by jmbmommy NC7 (My Page) on
Thu, May 31, 07 at 17:10

I have had 6 East Freisland salvias in my yard for 3 years now. The first year they did great, last year they never really grew and bloomed sporadically. This year - they look sad. They already tried to bloom, but there were hardly any flowers at all. They get full sun, planted in the same bed as my May Night salvias that are just beautiful! Any ideas/thoughts on reviving them? Thanks!


Follow-Up Postings:

 o
RE: salvia not blooming

The Easter freeze along with the plant getting tired in its location is probably part of the problem. Nemerosa and pratensis varieties are alpine and tap rooted. They can't renew themselves by layering and are short-lived in hot humid climates. Division and fertilization helps and is needed more frequently than in the northern states.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Salvia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here