Return to the Salvia Forum | Post a Follow-Up

 o
Salvia has huge leaves but no buds!

Posted by bluebird1989 6 (My Page) on
Thu, Jun 12, 14 at 6:48

The leaves of my salvia are getting larger and larger but the plant has no buds. I fed it with osmocote. We have had plenty of rain and the salvia is on east side of the house where it gets full sun most of the day. Any suggestions to help the plant flower?


Follow-Up Postings:

 o
RE: Salvia has huge leaves but no buds!

Which Salvia is it?


 o
RE: Salvia has huge leaves but no buds!

Yes, need to know which one. Some a Salvias don't bloom until Fall.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Salvia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here