Return to the Salvia Forum | Post a Follow-Up

 o
Black and Blue Salvia not blooming

Posted by margie5 z5 NY (My Page) on
Sun, Jul 1, 12 at 20:00

I have a Black and Blue Salvia that I overwintered in a pot in the garage. I divided it and planted out a large portion in a large pot in full sun with some other annuals (just like I did last summer). Got lots of beautiful blooms last summer, but this summer, it's making the bloom spikes, but no flowers are coming. The leaves look lush and happy. What's up with this? I love these flowers and I really want to see them with the other annuals I planted. Any suggestions?


Follow-Up Postings:

 o
RE: Black and Blue Salvia not blooming

An image of the non-blooming spikes might help. If the calyxes develop and persist, they should bloom.


 o
RE: Black and Blue Salvia not blooming

My zone 8b black & blues just started blooming this week (two whole blossoms so far out of three plants), so they can be slow sometimes....


 o
RE: Black and Blue Salvia not blooming

I have a similar situation with a b and b I overwintered in the garage has lots of spikes but maybe only 4 or 5 blooms. I have a third year plant right beside it that has lots of blooms but this intense heat is definitely affecting them. Im not worried about them though when this heat lets up next week they should do better.


 o
RE: Black and Blue Salvia not blooming

  • Posted by edie_h 5bNY (Finger Lakes) (My Page) on
    Sat, Jul 14, 12 at 15:48

Glad it's not just me. I overwintered two in the garage and they are now filling a 22" pot, but no blooms. I thought I must have done something wrong. Yesterday I finally saw a tiny bud that wasn't another pair of leaves - the first flower buds of the season.

Local nurseries sold B&B cuttings already blooming in May. Does anyone know what triggers or prevents flowering in this one?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Salvia Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here