Return to the Sansevieria Forum | Post a Follow-Up

 o
pinguicula question

Posted by MARIE_GA z7b/8GA (My Page) on
Sun, Dec 19, 04 at 17:58

Hi All! I'm new to this particular forum. I ordered a Pinguicula last spring and when it came to me it had two babies attached. Since then it has not reproduced anymore babies. Is this normal and if so how long does it usually take for it to make more babies? I really thought I would have one or two more by now. Thanks!!


Follow-Up Postings:

 o
RE: pinguicula question

  • Posted by Cena S CA 10A (My Page) on
    Sun, Dec 19, 04 at 21:23

I find this whole plant rather slow growing. I would not worry, and I suspect that this is quite normal for this plant.

Good luck with it. I especially like the babies putting out roots that support the plant up in the air, looking like its walking on stilts!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Sansevieria Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here