Return to the Southern Gardening Forum | Post a Follow-Up

 o
Carolina Jasmine Problem

Posted by itsmekarak 8 - DFW (My Page) on
Mon, Mar 26, 07 at 0:45

Hi Everyone! Three days agao we purchased and planted a Carolina Jasmine plant and today I noticed that almost all the blooms have fallen off. Does anyone have an idea of what may have caused this? I planted it in a rich compost medium in a partial shade area. Any thoughts?


Follow-Up Postings:

 o
RE: Carolina Jasmine Problem

Likely transplant shock. It could be due to over or under watering after transplanting, or over fertilization. But the simple shock of being transplanted is often enough to knock the blooms from a plant.


 o
RE: Carolina Jasmine Problem

It may put out new blooms this year, but it probably won't. Don't worry, it will come out again next year.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Southern Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here