Return to the Southern Gardening Forum | Post a Follow-Up

 o
Gardenias

Posted by Maybrc 7-8 (My Page) on
Sun, Mar 20, 05 at 14:30

Hi everyone! I have a gardenia bush that hasn't bloomed in the last two years. It looks healthy as far as I can tell.
Any ideas why it has not been blooming?????

Thanks a bunch!

Valerie


Follow-Up Postings:

 o
RE: Gardenias

I forgot to mention that this gardenia bush is outside. It gets enough water so I at a loss about what to do.
Thanks!


 o
RE: Gardenias

Is your gardenia in the sun? They do need a lot of sun to bloom. Or are you fertilizing with a high nitrogen fertilizer? That can cause leaf growth at the expense of flowers. Also sometimes gardenias seem to have heavy bloom in alternate years. But you've had yours for two years, so that shouldn't be a factor. Sorry, except for sun and nitrogen, I don't have any ideas for you.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Southern Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here