Return to the Southwestern Gardening Forum | Post a Follow-Up

 o
Tulip Tree in 2nd year, partially brown leaves

Posted by greeenmonster 10 (My Page) on
Fri, Sep 6, 13 at 15:43

I am wondering what might be causing this? We water it, is it not getting enough or too much? So hard to figure out. I thought that if it was not enough water the whole leaf would turn brown. We love our tree and want it to flourish!


Follow-Up Postings:

 o
RE: Tulip Tree in 2nd year, partially brown leaves

What is the watering schedule for it?

And where in Zone 10 are you?


 o
RE: Tulip Tree in 2nd year, partially brown leaves

This tree looks like a sycamore. If it a Tulip Tree (Liriodendron), Zone 10 is way out of it's comfort zone they like a lot of moisture. These leaves look very water stressed and may be salt burned too.
Have you seen any leafhoppers on the tree? They spread a leaf scorch that really affects sycamores.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Southwestern Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here