Return to the Terrariums Forum | Post a Follow-Up

 o
Bad if mushrooms are growing in my terrarium?

Posted by sunnyvalley Phoenix (My Page) on
Mon, Aug 11, 14 at 13:10

I just noticed I have mushrooms growing in my terrarium! Their growth seems only very recent, which is kinda odd considering it's over 6 months old and I've never opened it. Maybe I need to air it out a bit.

I think they look kinda cool so I'd be happy just picking out the dead ones, but I wondered if this is harmful to my plants. What concerns me isn't really the mushrooms themselves, but in the picture you'll notice a fine white sort of dusting on the soil and even on the leaves directly above the mushroom area. It isn't fuzzy or anything, and it doesn't seem to be killing the plants (yet?). Not sure if that's from the mushrooms, or a coincidental other mold/fungus, or simply a result of condensation? (I neglected to rotate it much and that's the side where most moisture has been collecting.) Advice appreciated!


Follow-Up Postings:

 o
RE: Bad if mushrooms are growing in my terrarium?

Hi SunnyValley,
From DianaMay's post on closed terrariums: "White furry mold should be rubbed gently with a finger to disturb it as soon as it is noticed. Usually it will not persist if you rub it down a few times."

I had some mushrooms growing in one of mine, and then got some rust on the ferns. Let it air out a little and cut off the fronds with the rust, pulled all the mushrooms. Sounds like you might have some of that white mold Diana mentioned. I'd try to get rid of it. I see you've got an asparagus fern in there, though I'm not sure what the other plants are.

I'd also get rid of the mushroom before it releases more spores.

In general, it may simply be some spores that were in there or got in there, and that's what caused the mushroom to grow!

No need to redo your terrarium, these things do clear up. Yours looks pretty good!

Best,
Judy


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Terrariums Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here