Return to the Growing Tomatoes Forum | Post a Follow-Up

 o
Tomatoes have quit blooming - help!

Posted by chrisro 8LA (My Page) on
Sun, May 30, 10 at 9:53

My better boy tomato plants have put on tomatoes and are getting ripe at this time. These were of the first blooms after planting. My problem is now they are not blooming and if they are, they are not producing tomatoes. We have had only about 1-1/2 inches of rain in the last 2 months and we have been watering periodically. I did put 8-8-8 in the hole when planting and have fertilized again approximately 6 weeks ago with the same. I'm wondering if I should use miracle grow on the leaves. Can anyone help? Thanks


Follow-Up Postings:

 o
RE: Tomatoes have quit blooming - help!

MG on the leaves has often lead to burned leaves. You should fertilize at least once a month. I fertilize weekly with a 1/4 strength fertilizer.


 o
RE: Tomatoes have quit blooming - help!

Are your plants in containers or in the ground? Makes a big difference when it comes to feeding and watering. I'm guessing in-ground since you mention "in the hole"? In-ground plants I feed approx. every 6 weeks. In containers I feed weekly.

Blooming and ripening does go in cycles normally so it may just be timing. Then again if they bloom but don't set fruit it could be a condition related to air temperatures called "blossom drop". There is a FAQ here about it with details.

Lastly, does the plant otherwise appear healthy with no signs of pests? Or is it possible you have been over-watering? How much as how often?

Dave


 o
RE: Tomatoes have quit blooming - help!

Dave, thanks for the info. It is possible it is "blossom drop" as the places where the blooms should be look dead. I will check FAQ on this.

They are not as healthy as they should be as the bottom leaves are turning yellow with black spots. Do you know what this or cause? Probably a FAQ on this also, I will check

Thanks again, Chris


 o
RE: Tomatoes have quit blooming - help!

Chriso,

I'm in the panhandle of Florida by Destin. Our weather has been hot and humis the past two weeks. When the wx gets this hot the plants won't set fruit. Just the way it is!! You aren't doing anything wrong, nature just has it's own rules!!

Bing


 o
RE: Tomatoes have quit blooming - help!

Thanks Bing, I am in middle Louisiana and our temps have been as high as 95 and humid. I guess I just don't remember having this problem before. Usually the better boys continually bloom, however I have not been spraying with miracle grow like I normally do.

I have new space which my husband covered with a cage to keep the squirrels from eating the tomatoes. I put several bags of composted cow manure when we were preparing the ground in early spring and I think this has been beneficial. Do you know about the yellowing leaves with black spots? Thanks again.


 o
RE: Tomatoes have quit blooming - help!

Chris,

Sorry...meant humid, not "humis"!! Google tomato plant diseases or something to that effect. There are lots of sites that show good pics of different problems. Then you can compare to what you've got. Also, "DIGDIRT" is very knowledgeable (much more so than I). Give him another yell. There's early blight, late blight, bacterial spot and a bunch of other problems. I've gotten blight this year and just took up my first plant which has wilt, I believe. Have never has any problems growing in containers but think the very hot and humid weather this early has caused some of this.

cheers and good luck

Bing


 o
RE: Tomatoes have quit blooming - help!

My Better Boys are not doing well. I have one plant that is stunted. It does have a few tomatoes that came on early. But the plant has not grown much since and has just a few "small" flowers. The other Better boy is not flowering. Between the two Better Boys are Early girls which are doing real well. I also have four heirlooms that are beautiful, tall and filled with fruit. My soil was perfect in the beginning. I sent a sample to have it analyzed before planting and amended the soil according to the university's advice. I only fertilized once about a month ago with MG tomato and veg food. I water (with a soaker hose twice a week for 40 min. each time. We are not having much rain and the temps have been in the 90's for two weeks. Any suggestions? Thanks!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Growing Tomatoes Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here